Installing Jekyll on Mac

In this post, we will install Jekyll on a recent MacBook Pro running Yosemite 10.10 OS. Apparently, installing Jekyll on recent MacBook Pro could be problematic. The error ERROR: Failed to build gem native extension appears in the terminal.

 

Normal install of Jekyll

Installation of Jekyll is usually very easy:

  • open the terminal
  • add the following lines:
  • sudo gem install jekyll

This is it!

 

Problem with MacBook Pro

Installing Jekyll on recent MacBook Pro could be problematic. If you get the following message, your installation went somehow wrong:

ERROR:  Error installing jekyll:
ERROR: Failed to build gem native extension.

 

The solution

The solution is to install the app Xcode on you mac. You can find it in your apple store or online in https://developer.apple.com/xcode/.

Actually, the best way to install Xcode is to add the following command in your Terminal app:

xcode-select --install

Once your Xcode app is intalled, you can install again Jekyll using:

sudo gem install jekyll

 

Update Jekyll

sudo gem update jekyll